HypeBeast.com loading relatively slower than other sites?

February 03, 2013 @ 06:29:15 AM
Post: 1410
Join Date: Mar 2012
Location: stockton
Idk if this is just me, but HB is loading slow as fuck, whereas all other sites are loading just fine. Specifically, the forums.Those tech guys gotta prioritize what their doing  to the site.
February 03, 2013 @ 07:03:15 AM
Post: 3045
Join Date: Feb 2012
Location: Hansumville
I noticed the exact same. I was thinking it was my internet but no other sites have been messing up.

Chicks barely dancin, glancin every chance they get, like - oh shit, he's so HANSUM

February 03, 2013 @ 23:46:24 PM
Post: 5750
Join Date: Nov 2011
Location: CBR, Down Under
HB is always way slower, needs fixin ASAP

instagram/twitter/snapchat : dadonnyd

February 04, 2013 @ 14:50:31 PM
Post: 4654
Join Date: Apr 2012
HB doesn't give a fuck about the forums. They're getting paid for the ad-space regardless, and all IT effort is put into the shop, where there's a good return on investment. This forum is the shittiest website I regularly go on, from an IT perspective.
February 04, 2013 @ 15:16:03 PM
Post: 94
Join Date: Apr 2012
Location: pittsburgh,
Id be on here more if this website wasnt fucked i open shit in a new tab and chrome just gives up  This mobile shit worse than the original fb app HB like your cousins shitty car when ur young but you forced to use it as a vessel cause none of u have whipgame and that fuck nigga KTT hes your neighbor but he drive a mini van and got a bunch of weird friends you dont fuck with that smoke reg but dont care cause its cost efficent cause they all in tech school and go to tech nine shows on the weekend when you need em
February 05, 2013 @ 08:33:52 AM
Post: 80
Join Date: Dec 2010
Location: Hong Kong
The site should be faster now, we will keep monitor it.
February 05, 2013 @ 23:13:08 PM
Post: 334
Join Date: Mar 2012
Location: Chicago
glad to hear it isn't just me, I can't load half the forum threads anymore
March 27, 2013 @ 14:23:10 PM
Post: 2
Join Date: Mar 2013
Location: FL
now is working fine. I had the same problems in the past weeks.

This post is hidden due to user account is no longer active or improper post content.

October 19, 2013 @ 06:24:43 AM
Post: 775
Join Date: Aug 2012
Location: 818/718
Sometimes it just appears blank, and I have to refresh a few times. 
Please login first to reply.
x