Free Worldwide Shipping
Spend $150 USD or more. Click for details.
May 7, 2012 @ 01:03 AM
DarthVader

Post: 1536

Join Date: Apr 2012

Location: San Francisco

When I try to login it just tries to log me in but it still says LOGIN and SIGN UP. But when I go to a incognito window and sign in, its perfectly fine. Please help if you can. Thanks.
May 7, 2012 @ 01:45 AM
Warren

moderator

Post: 458

Join Date: Aug 2011

Location: Hypebeast HQ

Hi, please clear your browser's cache for the time being as we try to deal with this problem.

Hypebeast: User and Forum Support

May 7, 2012 @ 03:09 AM
DarthVader

Post: 1536

Join Date: Apr 2012

Location: San Francisco

Hi, please clear your browser's cache for the time being as we try to deal with this problem.

Cleared my cache and still the same problem. I'm stuck using HB in a icognito window.
May 7, 2012 @ 03:13 AM
Warren

moderator

Post: 458

Join Date: Aug 2011

Location: Hypebeast HQ

strange, what browser are you using?

Hypebeast: User and Forum Support

May 7, 2012 @ 03:19 AM
DarthVader

Post: 1536

Join Date: Apr 2012

Location: San Francisco

Google Chrome
May 7, 2012 @ 03:41 AM
Warren

moderator

Post: 458

Join Date: Aug 2011

Location: Hypebeast HQ

make sure that you clear all cache and not just past day, i.e beginning of time

Hypebeast: User and Forum Support

May 7, 2012 @ 03:48 AM
DarthVader

Post: 1536

Join Date: Apr 2012

Location: San Francisco

I did. I cleared my cache from the beginning of time. Shit's pissing me off.
May 7, 2012 @ 03:58 AM
Warren

moderator

Post: 458

Join Date: Aug 2011

Location: Hypebeast HQ

try going into here.

Random Hypebeast Link

Hypebeast: User and Forum Support

May 7, 2012 @ 05:24 AM
DarthVader

Post: 1536

Join Date: Apr 2012

Location: San Francisco

^Worked! :D
Thanks man! Appreciate your help.

Please login first to reply.
Back To Top