Free Worldwide Shipping
Spend $150 USD or more. Click for details.
July 13, 2011 @ 02:43 AM
Beach2theBay

Post: 3284

Join Date: Apr 2009

Location: Long Beach,CA

Trying to get some opinions on this

So I got a cd player installed in my 318ti on Friday and right after I pulled onto the street out of the shop my car turned off at the light. It started back up and I drove home and it turned off once more and had been fine since. Monday I went back to the shop and told them about the problem and they said I need a new battery. I believed them and decided to get some speakers and figured id get a new battery later. After I left the shop my car did the same thing as Friday. I had been there forever getting the speakers done so I may go back tomorrow. I also noticed that the car starts rumbling like it's going to turn off when the volume is past 30. Is this a battery problem or did they do something wrong?

Check out my podcast Music Mongrel Podcast on iTunes

July 13, 2011 @ 09:09 AM
ahhhrt

Post: 2005

Join Date: Aug 2006

Location: toe ron toe

Could be a battery problem, could be an alternator problem, could be faulty install.
July 13, 2011 @ 10:15 AM
unknown force.

Post: 3969

Join Date: Nov 2007

Location: san diego

time to update dem grounds ♥♥♥♥♥
July 13, 2011 @ 11:09 AM
Hellah Fresh

Post: 3884

Join Date: Dec 2006

time to update dem grounds ♥♥♥♥♥


this.
July 13, 2011 @ 01:27 PM
Beach2theBay

Post: 3284

Join Date: Apr 2009

Location: Long Beach,CA

time to update dem grounds ♥♥♥♥♥


Explain what that is in English. I don't know if it's a battery thing because my car starts up after it shuts off. My battery isn't dead.

Check out my podcast Music Mongrel Podcast on iTunes

July 13, 2011 @ 03:25 PM
unknown force.

Post: 3969

Join Date: Nov 2007

Location: san diego

ground wires need upgrading and or checking?
July 13, 2011 @ 04:05 PM
Beach2theBay

Post: 3284

Join Date: Apr 2009

Location: Long Beach,CA

cool ill check that out. im gonna take my car to another shop and see what they say.

Check out my podcast Music Mongrel Podcast on iTunes

July 13, 2011 @ 04:37 PM
TheCityOfChi

Post: 4615

Join Date: Nov 2006

It could be the grounds, but that sounds like a weird problem. I doubt anythnig with a cd player would affect the battery. Unless they did a shitty job of installing it and cut some corners
July 14, 2011 @ 03:38 PM
The Main Event

Post: 1429

Join Date: Jul 2006

Location: NJ

ground wires need upgrading and or checking?


Sounds like it
July 14, 2011 @ 06:01 PM
unknown force.

Post: 3969

Join Date: Nov 2007

Location: san diego

It could be the grounds, but that sounds like a weird problem. I doubt anythnig with a cd player would affect the battery. Unless they did a shitty job of installing it and cut some corners


bad grounds cause lots of weird problems
July 15, 2011 @ 01:40 AM
Beach2theBay

Post: 3284

Join Date: Apr 2009

Location: Long Beach,CA

I got my battery and alternator checked and the dude said they were fine. I'm gonna take my car back to the shop and tell them to look at it. Those fuckers better not argue with me.

Check out my podcast Music Mongrel Podcast on iTunes

July 17, 2011 @ 03:04 AM
Beach2theBay

Post: 3284

Join Date: Apr 2009

Location: Long Beach,CA

Well this thread had a lot of views so I thought I'd update everyone. I went back today and told them I got my battery and alternator checked and to fix my shit. The guy got in the car and turned my radio up and my car cut off as usual. He was like "that must be something else. The stereo isn't related to power." I said "dude you just turned it up and it cut off. It didn't cut off before you did that so obviously that caused it." I argued with him for like 5 minutes then he had another dude take the cd player out and do something to it. It doesn't cut off anymore but I have a feeling the guy just lowered how high my cd player can go so I can't reach 30 and make it cut off anymore haha.

Check out my podcast Music Mongrel Podcast on iTunes

July 17, 2011 @ 08:44 PM
unknown force.

Post: 3969

Join Date: Nov 2007

Location: san diego

did you check your grounds, or did you just ignore all advice given?
July 17, 2011 @ 09:17 PM
Beach2theBay

Post: 3284

Join Date: Apr 2009

Location: Long Beach,CA

I took it to my mechanic and he said they did something wrong and take it back to them. Everything seems fine now.

Check out my podcast Music Mongrel Podcast on iTunes

July 17, 2011 @ 09:25 PM
unknown force.

Post: 3969

Join Date: Nov 2007

Location: san diego

so wut ur sayin is no, you didn't listen
July 17, 2011 @ 09:28 PM
DonPedro

Post: 1242

Join Date: Nov 2007

Location: santa ana zoo

so wut ur sayin is no, you didn't listen


lmao
July 17, 2011 @ 10:47 PM
Beach2theBay

Post: 3284

Join Date: Apr 2009

Location: Long Beach,CA

so wut ur sayin is no, you didn't listen


I listened to a licensed mechanic (for free, family friend) and now my problem is fixed. What else you need?

Check out my podcast Music Mongrel Podcast on iTunes


Please login first to reply.
Back To Top