My car is cutting off after cd player install

July 13, 2011 @ 02:43:50 AM
Post: 3279
Join Date: Apr 2009
Location: Long Beach,CA
Trying to get some opinions on this

So I got a cd player installed in my 318ti on Friday and right after I pulled onto the street out of the shop my car turned off at the light. It started back up and I drove home and it turned off once more and had been fine since. Monday I went back to the shop and told them about the problem and they said I need a new battery. I believed them and decided to get some speakers and figured id get a new battery later. After I left the shop my car did the same thing as Friday. I had been there forever getting the speakers done so I may go back tomorrow. I also noticed that the car starts rumbling like it's going to turn off when the volume is past 30. Is this a battery problem or did they do something wrong?
July 13, 2011 @ 09:09:22 AM
Post: 1862
Join Date: Aug 2006
Location: toe ron toe
Could be a battery problem, could be an alternator problem, could be faulty install.
July 13, 2011 @ 10:15:08 AM
Post: 3861
Join Date: Nov 2007
Location: san diego
time to update dem grounds ♥♥♥♥♥
July 13, 2011 @ 11:09:40 AM
Post: 3581
Join Date: Dec 2006
Originally posted by Inactive User
time to update dem grounds ♥♥♥♥♥


this.
July 13, 2011 @ 13:27:14 PM
Post: 3279
Join Date: Apr 2009
Location: Long Beach,CA
Originally posted by Inactive User
time to update dem grounds ♥♥♥♥♥


Explain what that is in English. I don't know if it's a battery thing because my car starts up after it shuts off. My battery isn't dead.
July 13, 2011 @ 15:25:22 PM
Post: 3861
Join Date: Nov 2007
Location: san diego
ground wires need upgrading and or checking?
July 13, 2011 @ 16:05:05 PM
Post: 3279
Join Date: Apr 2009
Location: Long Beach,CA
cool ill check that out. im gonna take my car to another shop and see what they say.
July 13, 2011 @ 16:37:38 PM
Post: 4380
Join Date: Nov 2006
It could be the grounds, but that sounds like a weird problem. I doubt anythnig with a cd player would affect the battery. Unless they did a shitty job of installing it and cut some corners
July 14, 2011 @ 15:38:17 PM
Post: 1356
Join Date: Jul 2006
Location: NJ
Originally posted by Inactive User
ground wires need upgrading and or checking?


Sounds like it
July 14, 2011 @ 18:01:49 PM
Post: 3861
Join Date: Nov 2007
Location: san diego
It could be the grounds, but that sounds like a weird problem. I doubt anythnig with a cd player would affect the battery. Unless they did a shitty job of installing it and cut some corners


bad grounds cause lots of weird problems
July 15, 2011 @ 01:40:24 AM
Post: 3279
Join Date: Apr 2009
Location: Long Beach,CA
I got my battery and alternator checked and the dude said they were fine. I'm gonna take my car back to the shop and tell them to look at it. Those fuckers better not argue with me.
July 17, 2011 @ 03:04:42 AM
Post: 3279
Join Date: Apr 2009
Location: Long Beach,CA
Well this thread had a lot of views so I thought I'd update everyone. I went back today and told them I got my battery and alternator checked and to fix my shit. The guy got in the car and turned my radio up and my car cut off as usual. He was like "that must be something else. The stereo isn't related to power." I said "dude you just turned it up and it cut off. It didn't cut off before you did that so obviously that caused it." I argued with him for like 5 minutes then he had another dude take the cd player out and do something to it. It doesn't cut off anymore but I have a feeling the guy just lowered how high my cd player can go so I can't reach 30 and make it cut off anymore haha.
July 17, 2011 @ 20:44:50 PM
Post: 3861
Join Date: Nov 2007
Location: san diego
did you check your grounds, or did you just ignore all advice given?
July 17, 2011 @ 21:17:32 PM
Post: 3279
Join Date: Apr 2009
Location: Long Beach,CA
I took it to my mechanic and he said they did something wrong and take it back to them. Everything seems fine now.
July 17, 2011 @ 21:25:18 PM
Post: 3861
Join Date: Nov 2007
Location: san diego
so wut ur sayin is no, you didn't listen
July 17, 2011 @ 21:28:25 PM
Post: 1210
Join Date: Nov 2007
Location: santa ana zoo
Originally posted by Inactive User
so wut ur sayin is no, you didn't listen


lmao
July 17, 2011 @ 22:47:12 PM
Post: 3279
Join Date: Apr 2009
Location: Long Beach,CA
Originally posted by Inactive User
so wut ur sayin is no, you didn't listen


I listened to a licensed mechanic (for free, family friend) and now my problem is fixed. What else you need?
Please login first to reply.
x